Des del 30 de setembre del 2021, l'organització oficial de Let's Encrypt va informar d'un canvi que afectaria la manera com els navegadors i dispositius més antics confien en els certificats Let's Encrypt. Si executeu un lloc web típic, no notareu la diferència: la gran majoria dels visitants encara acceptaran el seu certificat Let's Encrypt.


La gran majoria de llocs accepten tots els certificats arrel presents a tots els dispositius i navegadors recents. Això no obstant, si el dispositiu és antic i fa anys que no rep suport ni actualitzacions, i per tant no rep la compatibilitat amb versions recents, el certificat arrel es pot convertir en un problema.


Per poder accedir de forma segura a una pàgina web és necessari no només que aquesta utilitzi un protocol com HTTPS, sinó també tenir un certificat arrel compatible al dispositiu i al navegador utilitzats que certifiqui que les connexions són segures.


En resum, que si utilitzeu un dispositiu antic per navegar per internet, les pàgines web que tinguin instal·lat un Let's Encrypt us denegarà la connexió per no poder certificar aquest dispositiu.


Llistat de dispositius i sistemes que ja no suporta Let's Encrypt:


Windows XP con Service Pack 3
MacOS, con actualización menor a 10.12.1 (del 2016)
iOS, con actualización menor a iOS 10 (iPhone 5 es el modelo más antiguo que puede actualizarse a iOS 10)
Android, con actualización mayor a 2.36 y menor a 7.1.1
Mozilla Firefox, superior a versión 2.0
Ubuntu, con actualización menor a 16.04
Debian, con versión menos a 8
Java 8, con versión menor a 8u141
Java 7, con actualización menor a 3.26
Amazon FireOS
Kindle, superior a versión 3.4.1
Cyanogen, con versión mayor a 10
Consolas PlayStation con firmware mayor a 5.00
BlackBerry con versión superior a 10.3.3


IMPORTANT : Volem remarcar que el certificat gratuït que ofereix cdmon  és el Let's Encrypt, per això aquests canvis també afecta els hostings que el tingui instal·lats, així que els visitants que tinguin algun d'aquests dispositius/sistemes antics pot ser bloquejat d'accés per el propi certificat.


Podeu llegir el comunicat oficial des de la seva pàgina web: https://letsencrypt.org/es/docs/dst-root-ca-x3-expiration-september-2021/